TYPO3-EXT-SA-2019-023: CSRF in extension "femanager" (femanager)

  • Release Date: December 17, 2019
  • Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.
  • Vulnerability Type: Cross-Site Request Forgery
  • Affected Versions: 5.1.1 and below
  • Severity: Medium
  • Suggested CVSS v3.1: AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:N/E:F/RL:O/RC:C
  • CVE: Not assigned yet

Problem Description

The extension fails to implement a CSRF protection for edit and delete actions.

Solution

An updated version 5.2.0 is available from the TYPO3 extension manager, Packagist and at

https://extensions.typo3.org/extension/download/femanager/5.2.0/zip

Users of the extension are advised to update the extension as soon as possible.

Note: Make sure to read the release notes, since manual templates changes are required in case template Templates/Edit/Edit.html or Partials/Misc/DeleteLink.html have been modified individually.

Credits

Credits go to Helmut Hummel who discovered and reported the vulnerability.

General Advice

Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.

Zurück